Loading...
 

Grafiken erstellen mit SolidWorks und Lemuria



dieses Tutorial wurde 2011 von Lemuria erstellt

Nachdem der Release von pak.German128 Rev 0.1 nun geglückt ist und sich vielleicht doch der eine oder andere an einer Mitarbeit am Pak-Set interessieren könnte, möchte ich hier eine Art “Step-by-Step”-Anleitung für das Erstellen von Simutrans-Grafiken mit der CAD-Software Solidworks (SWX) zum Besten bringen. Ich werde mich bemühen, sehr detailliert und verständlich zu schreiben, um ein Einsteigen in die 3D-Modellierung, Texturierung usw. ohne jegliche Vorkenntnisse im Computer-3D-Orbit möglich zu machen.


Die Vorlagelink

Bild 1
Bild 1


Beim Start von Solidworks, bzw. nach dem Öffnen der Vorlage sollte das Ganze in etwa so aussehen. Oben ist der sogenannte Befehlsmanager eingeblendet, der die wichtigsten und gängigsten Befehle und Bearbeitungsmöglichkeiten enthält, auf der linken Seite der sogenannte „Feature-Baum“, in dem alle Modellier-Elemente aufgelistet sind. Dieser wird bei jedem Modell-Neuaufbau von oben nach unten neu berechnet – d.h. man kann auch bereits bestehende Feature noch im Nachhinein verändern, alles andere wird dann auf die neue Geometrie umgerechnet…. Klingt jetzt noch ein wenig kompliziert – ist dann später aber selbsterklärend.
Die Vorlage ist im Grunde eine modellierte Bodenplatte, mit einer Seitenlänge von 90.5mm – Solidworks als Maschinenbauprogramm rechnet ja in mm und nicht in Pixel – allerdings ergibt die Diagonale dieses Quadrats eine Länge von 127.99mm also ziemlich genau den 128-Mass des Pak128 oder Pak128.German. Also entspricht eine Länge von 1mm dann ziemlich genau einem Pixel in der Rendergrafik.

3D auf dem flachen Bildschirm???link

Die Bewegung im Raum ist auch relativ einfach:
- Mausrad drehen ist Zoomfunktion
- Mausrad drücken und die Maus bewegen dreht das Modell
- Strg+Mausrad drücken verschiebt das Modell nach links/rechts/oben/unten
- Leertaste öffnet das „Ausrichtungs-Menü“ in dem vordefinierte Ansichten ausgewählt werden können.
Bild 2
Bild 2

Die Ansichten Render 1-4 sind dann schlussendlich die 4 Ansichten, die für Simutrans benötigt werden, also unter ca. 30° Blickwinkel entlang der Diagonalen.
Wenn man eine Fläche ausgewählt hat, und dann *Normal auf wählt, wird das Modell so gedreht, dass man auf die ausgewählte Fläche blickt. Wählt man 2 Flächen (unter drücken von Strg) aus, wird auf die zuerst ausgewählte Normal gedreht und zwar so, dass die zweite Fläche oben ist.
- Wichtig ist noch die Taste „F“ – sie zentriert das Modell im Modellbereich und stellt den Zoom so ein, dass das Modell den Modellbereich halbwegs ausfüllt.

Photoworks und seine Buttonslink

Photoworks wird nicht gleich bei jedem SWX-Start mitgestartet. Also müssen wir erstmal dafür sorgen, dass das Ding läuft. Im Befehlsmanager gibt es den Reiter „Office Produkte“ – wird dieser ausgewählt erscheint ganz links ein Button „Solidworks Office“. Wird dieser gedrückt erscheint unten eine Liste mit allen möglichen mehr oder weniger nützlichen Zusatzprogrammen unter denen auch Photoworks zu finden ist. Dieses einfach anklicken – einen Moment warten – und sich dann drüber freuen, dass neue Buttons im Befehlsmanager erscheinen Wink
Bild 3
Bild 3


Was hier wichtig ist:
- Rendern: Ist natürlich der wichtigste Button – wird er gedrückt, wird der Modellbereich in der aktuellen Ansicht gerendert. Also sieht unser Modell jetzt so aus:
Bild 4
Bild 4

Natürlich noch nicht weltbewegend… mit drehen/zoomen/verschieben wird der Modellbereich wieder „normal“
- Erscheinungsbild: mit diesem Button öffnet man das Menü, in welchem man bestimmen kann, wie ein Feature/Fläche oder was auch immer dann am Schluss im gerenderten Bild aussehen soll – dazu später mehr.
- In Datei Rendern: wird am Ende dazu benötigt um die 4 Ansichten in Dateien zu bringen, die man mit Gimp oder anderen Grafikprogrammen nachbearbeiten und dann in Simutrans integrieren kann.
- Kopieren/Einfügen: sehr wichtig: übernimmt die Textur/das Aussehen eines Features und übergibt es an ein anderes. Spart viel Arbeit und lässt gleiche Texturen gleich aussehn…
- Der Rest ist in erster Linie Spielerei – kann man sich mal ein wenig durchklicksen und rumprobieren, allerdings ist das nötigste erklärt.

Das Vorbildlink

Microsoft kann doch dein Freund sein – bzw. die Vogelperspektive von BingMaps. Hier lassen sich nahezu unendlich Vorbilder für Häuser, Industriegebäude, Monumente etc. finden – natürlich muss man diese oft ein wenig an die Simutrans-Gegebenheiten anpassen, aber mit ein wenig Fantasie ist das kein Problem. Für das Tutorial hab ich mal ein recht schlichtes Gebäude ausgesucht:
Bild 5
Bild 5


Am Anfang ist dann doch 2Dlink

Nun kommt der erste große Schritt – das erste Feature für das neue Gebäude entsteht. Dazu wird im Befehlsmanager der Reiter „Features“ ausgewählt und der Befehl „Linear ausgetragener Aufsatz“ gewählt. Sofort schreit SWX, dass man eine Ebene oder planare Fläche für das Querschnittsfeature auswählen soll. Das heißt, dass man die Fläche für den Grundriss auswählen soll. Also auf die Kachel klicken und man gelangt in den „Skizzenmodus“. SWX schaltet den Befehlsmanager automatisch auf „Skizze“ und im Modellbereich erscheint in der rechten oberen Ecken eine Bleistift und ein rotes Kreuz.
Um die Ansicht normal auf die Skizze auszurichten, reicht im Normalfall ein Druck auf Leertaste und dann *normal auf.

Bild 6
Bild 6


Im Befehlsmanager befinden sich nun die wichtigsten Dinge, die man in einer Skizze verwenden kann. In dem Fall findet der Befehl „Rechteck“ Verwendung – also auswählen und locker fröhlich mal ein Rechteck auf die Fläche zimmern…

Bild 7
Bild 7


Nun haben wir ein Rechteck, das frei auf der Fläche rumschwirrt, nicht mal weiß wie groß es sein soll und sich nach einem festen Platz sehnt. Das erkennt man daran, dass es blau ist. Das Zauberwort heißt „Intelligente Bemaßung“. Den Button anwählen, z.B. eine Kante auswählen – dann kann man die Länge der Kante definieren; wählt man 2 Kanten aus, wird der Abstand zwischen den beiden definiert, ein Kreis bekommt einen Durchmesser usw. auswählen kann man nahezu alles, auch Kanten, Flächen, Punkte, Ebenen usw. die bereits Teil des Modells sind.

Bild 8
Bild 8


Wir bestimmen nun das Rechteck mit den Seitenlängen 80 und 50 und positionieren das ganze vom linken Rand 6mm weg. Dadurch werden 2 senkrechten Linien schwarz – also voll definiert, die 2 anderen sind immer noch blau, da ja das ganze Rechteck noch nach oben und unten verschoben werden kann. Hier kommt das 2. Zauberwort im Skizziermodus zum Einsatz: die Beziehung.
Es gibt eine ganze Reihe von Beziehungen, die das Leben in der Skizze einfacher machen. Für eine Beziehung werden (fast) immer mindestens 2 Elemente benötigt, sobald diese ausgewählt werden, erscheint auf der linken Seite eine Auswahlmöglichkeit an Beziehungen die mit diesen Elementen möglich sind.
Wenn man die aktuelle Skizze betrachtet, sind sogar schon 4 Beziehungen eingetragen: die 4 türkisen Kästchen zeigen an, dass die Linien als waagerecht bzw. senkrecht definiert sind – das wird bei Rechtecken standardmäßig eingefügt.
In dieser Skizze wollen wir nun das Rechteck in z-Richtung mittig positionieren. Dazu wählen wir den Befehl „Mittellinie“ (dieser ist versteckt hinter der Linie anzutreffen) und zeichnen uns einfach eine waagerechte Mittellinie.

Bild 9
Bild 9


Nun wählen wir den linken Endpunkt der Mittellinie und die rechte Kante des Rechtecks an, und SWX sagt uns was es damit machen will:

Bild 10
Bild 10


Wir entscheiden uns nach kurzer Überlegung für „Mittelpunkt“. Das gleiche Spiel auf mit dem anderen Ende der Mittellinie und der rechten Kante der Grundkachel:

Bild 11
Bild 11


Bild 12
Bild 12


Und siehe da: alles schwarz und SWX schreibt unten in der Statusleiste „voll definiert“.
Nun folgt ein Klick auf den Bleistift in der rechten oberen Ecke und wir verlassen den Skizzenmodus und können uns um das Feature kümmern…

Die 3. Dimensionlink


Bild 13
Bild 13


Die Ansicht habe ich hier bereits auf „Render 1“ gedreht. Das müsste mittlerweile schon funktionieren, ansonsten sollte man weiter oben noch einmal nachlesen.
Wir befinden uns nun im „Feature Bearbeiten“-Modus für unseren ersten „Linear ausgetragenen Aufsatz“. Das gelb eingefärbte ist die Vorschau, grün gefärbt unsere fertige Skizze und links wieder die Möglichkeit alles Mögliche einzustellen. Da kann man ein wenig selbst rumprobieren, die meisten Sachen sind eigentlich selbsterklärend…
In unserem Fall hat unser Gebäude 4 Stockwerke. Als Richtwert für eine Etagenhöhe im Pak128.German kann man 16mm verwenden. Dieser kann natürlich leicht variieren – ein altes Bauernhaus hat zumeist etwas niedrigere Stockwerke, ein Fabrikshalle oder ein Prunkbauwerk ist meist wesentlich höher. Aber für das Standartwohnhaus ist dieser Richtwert ganz OK. Also 4 Stockwerke x 16mm = 64mm Gesamthöhe…

Bild 14
Bild 14


Bestätigen und unser Grundaufbau ist steht da…

Bild 15
Bild 15


Farbe in die Weltlink

Der Grundkörper des Häusls ist jetzt natürlich farblich noch etwas unansehnlich, deshalb ist der nächste Schritt die Farbgebung. An dieser Stelle beschränke ich mich zunächst auf die vordefinierten Texturen und Farben, die mit SWX mitgeliefert werden. Damit kann man schon einiges an farblicher Gestaltung realisieren, ohne ganz tief in die Texturenmaterie eindringen zu müssen.

Was man zunächst wissen sollte:
1. Solidworks hat mehrere Texturenebenen. In seinem Mikrouniversum behandelt es Texturen der Reihe nach von globaler bis kleiner. Doch was heisst das?
Alles, was nicht selbst definiert ist, wird in der Textur des Parts dargestellt. Dies ist der oberste Punkt im Feature-Baum. Ein Körper (dazu später mehr) kann ein eigenes Erscheinungsbild haben. Wird einem Feature ein Erscheinungsbild zugewiesen, erhalten alle Flächen, die durch dieses Feature definiert sind dieses Erscheinungsbild. Dieses kann man nochmals übertönen, in dem man einer Fläche eine eigene Textur zuweist.

Bild 16
Bild 16


Das Bild zeigt die Reihung -> in dem Fall werden die Texturen von unten nach oben überlagert
2. Eine Fläche bekommt und behält die Farbe, die sie im Featurebaum als erstes zugewiesen bekommt, behält sie auch. Das heißt, wenn ein Feature sich eine Fläche mit einem anderen Feature teilt, trägt am Ende die Fläche die Farbe des ersten Features – klingt kompliziert, ist es aber nicht.
3. Eine Fläche kann immer nur 1 Textur haben. Mehrfarbige Flächen gibt es nicht – hier muss man sich mit kleinen Tricks helfen, die dann später kommen.

Aber nun ans Werk:
Wir wählen unsere Austragung im Feature-Baum aus und wählen im Office-Reiter des Befehlsmanagers den „Erscheinungsbild“-Button.

Bild 17
Bild 17


Links erscheint wieder das Menü, auf der rechten Seite sollte sich der Erscheinungsbild-Browser einblenden. Kommt dieser nicht, kann er über die 4-farbige Kugel am rechten Fensterrand eingeblendet werden. Im Großen und Ganzen ist das jetzt relativ easy – oben kann man sich durch die Ordner durchklicken, unten erscheint der Ordnerinhalt, ein Klick auf ein Beispielbildchen übergibt die Farbe ans Feature.
Hier wähle ich aus dem Pfad „Stein“ -> „Architektonisch“ –> „Sandstein“ den gelben Sandstein aus, bestätige und der Quader färbt sich in der Farbe ein.

Bild 18
Bild 18


Gerendert sieht das Ganze dann so aus:

Bild 19
Bild 19


Die nächste Skizzelink


Betrachten wir nun die Vorlage nochmals, sehen wir einen dunklen Rand ums Dach. Dieser wird mit einer neuen Linearen Austragung gemacht…
Also wieder auf Lineare Austragung, als Fläche für die Skizze verwenden wir nun die Oberseite des Quaders, Normal ausrichten.

Bild 20
Bild 20


Natürlich könnte man nun wieder ein Rechteck um den Quader malen und dann alle 4 Seiten mit intelligenter Bemaßung definieren, aber hier gibt es ein recht hübsches Tool:
Man wähle die obere Fläche an

Bild 21
Bild 21


Und benutzt den Button „Offset-Elemente“ im Befehlsmanager.

Bild 22
Bild 22


SWX erstellt nun ein Abbild der ausgewählten Fläche und verschiebt die Außenränder 2mm nach außen – klingt praktisch, ist es auch. Bestätigen und man hat mit 3 Klicks und einer Zahleneingabe die Skizze für das nächste Feature fertig.
Den linearen Aufsatz gebe ich mit dem Wert 3 an und drehe wieder in die Render 1-Ansicht.

Bild 23
Bild 23


Noch Farbe zuweisen (wie oben), in diesem Fall verwende ich Stein -> Pflaster -> Dunkler Beton 2D

Bild 24
Bild 24


Das Dach - SWX hat keine Dachtexturenlink


Beim Dach kommen jetzt 2 neue Sachen dazu: schräge Flächen und eigene Texturen…
Beim Dach sind alle 4 Flächen schräg, deshalb kann man sich die Option „Formschräge“ im Linear Austragen-Feature zu Nutze machen, um das ganze recht flott hinzubasteln. Also wieder neue Lineare Austragung, Fläche ist wieder die oberste, Fläche auswählen, Offset, diesmal mit 3mm nach innen

Bild 25
Bild 25


Bestätigen - Skizze beenden...

Bild 26
Bild 26


Im ersten Schritt erhöht man die Höhe weit über dem was man benötigt – ich nehm mal 60…

Bild 27
Bild 27


Die Formschräge ist das lustige Zeichen unter „Ergebnis verschmelzen“, dieses aktivieren und den Winkel dahinter erhöhen und schauen was passiert….

Bild 28
Bild 28


Ich verwende jetzt mal 60°
Nun kann man in der Erscheinungsbildern lange nach Dachschindeln suchen, man wird sie nicht finden – also müssen wir selbst eine Grafik verwenden und zu einer Renderdatei umbauen. Keine große Action, nur ein paar Sachen müssen beachtet werden.
Also Feature auswählen und ins Erscheinungsbild gehen…
Als erstes muss man ganz oben von „Grundlegend“ auf „Erweitert“ umstellen. Dadurch erscheint im „Farbe/Bild“-Reiter ein „Durchsuchen“-Button:

Bild 29
Bild 29


Den wählen wir nun aus und suchen uns eine Bilddatei im Dateisystem, die unseren Vorstellungen entspricht.

Bild 30
Bild 30


Eine gar hervorragende Quelle für solche Bildchen ist cgtextures.com
Nach dem Bestätigen will SWX eine *.p2m-Datei speichern. Dies ist das Photoworks-Texturen-File in dem alle Lichteigenschaften etc. gespeichtert werden.
Nun zu den Einstellungen:
- Zunächst mal die Grösse des Bildes auf den Flächen
Bild 31
Bild 31

Das Pink-Blaue Viereck bei der Textur kann an den Ecken gezogen werden und vergrößert oder verkleinert dadurch die Textur.
- Die Beleuchtung: Hier entscheidet sich die Qualität der Grafik!!! Also in den Reiter Beleuchtung wechseln…
  • Für Simutrans-Renderings kann immer der Beleuchtungstyp „Kunststoff“ eingesetzt werden. Der ist recht einfach zu handhaben und bringt gute Ergebnisse.
  • Umgebungslicht und Diffus steuern die Helligkeit der Textur – also je kleinere Werte umso dunkler wird die Textur im Renderexport.
  • Glänzend gibt den Glanzfaktor an – also wie unterschiedlich sich eine Fläche im Licht aufhellt. Bei den meisten Materialien wie Stein, Holz etc. kann man diesen Wert getrost auf 0 setzen, interessant ist er eher für Metalle und Glas, wirklich interessant auf gekrümmten und runden Flächen. Aber auch hier sind Werte um die 0.5 leicht ausreichend.
  • Reflexionskraft gibt an, ob und wie stark sich Objekte auf der Fläche spiegeln. Schaut grundsätzlich genial aus, sollte aber nur gezielt und sparsam eingesetzt werden – schließlich sieht es dann in der Simutrans-Stadt eigenartig aus, wenn sich der Fahnenmast im Garten in den Fenstern spiegelt, das Nachbarhaus allerdings nicht. Sehr nützlich ist es allerdings für Wasserfläche oder ähnliches, wo das menschliche Auge die Spiegelung erwartet und dadurch das Wasser erst als Wasser erkennt.
  • Transparenz lässt dahinter liegende Flächen durchscheinen – aber eher Spielerei als nötig, schaut bei Fassadenverglasungen ganz cool aus, für Fenster allerdings schon zu viel des guten. Was man dabei unbedingt beachten muss: Transparente Flächen müssen in ALLEN 4 Ansichten komplett Flächen dahinter haben – Simutrans kann mit Transparenzen nicht umgehen und eine transparente Fläche wird in der endgültigen Simutrans-Grafik undurchsichtig. Sieht dann komisch aus, wenn die Mauer des Gebäudes hinter der Glasfassade durchscheint, die Mauer des Nachbarhauses aber nicht mehr…


Zurück zu unserm Häusl verwende ich für Umgebungslicht und Diffus die Werte 1 und alles andere 0. Bestätigen, Rendern dann sollte es ungefähr so aussehen:

Bild 32
Bild 32


Licht ins Dunkel – Fenster im Linearen Musterlink


Um die Fenster plastisch wirken zu lassen sollten sie als Vertiefung im Mauerwerk ausgeführt werden. Dazu verwenden wir den „Linear ausgetragenen Schnitt“. Vom Prinzip her funktioniert dieses Feature komplett gleich wie die Austragung, nur wird nach der Skizze Material abgetragen. Als erstes die Fenster auf der Südseite…

Bild 33
Bild 33


Als Richtwerte sind hier die Höhe 5 über dem Boden bzw. Etagenboden und die Höhe des Fensters mit 8 zu sehen. Die Breite ist dann relational dazu – aber auch hier wieder – NUR Richtwert, ein Kirchenfenster ist sicher grösser. Als Schnitttiefe verwende ich jetzt 0.5

Bild 34
Bild 34


Das Gebäude in München hat weisse Fensterrahmen – diese sind auch sehr schnell zu modellieren:
Lineare Austragung auswählen, als Skizzierebene den Grund der Ausnehmung des Fensters (also so quasi die Fensterscheibe auswählen). In der Skizze kann man dann mit dem Offset-Werkzeug arbeiten:

Bild 35
Bild 35


Die Option in 2 Richtungen erzeugt sowohl innen als auch außen die gewünschte Linie. Die Austragung dann ein wenig grösser als die Tiefe der Ausnehmung machen:

Bild 36
Bild 36


In weissem Mattglanzkunststoff einfärben:

Bild 37
Bild 37


Fertig ist das erste Fenster:

Bild 38
Bild 38


Jedes einzelne Fenster zu modellieren wäre jetzt natürlich eine qualvolle langwierige Arbeit, aber SWX hat auch hierfür sein Helferlein – das Lineare Muster:

Bild 39
Bild 39


Zunächst wählen wie die „Features für Muster“ aus: das wäre in diesem Fall der Schnitt 1 und die Austragung 4 – also die beiden Feature, mit denen wir das Fenster modelliert haben. Diese lassen sich auch aus dem Feature-Baum im Modellbereich auswählen, der auf der linken Seite erscheint:

Bild 40
Bild 40


Als Richtung 1 wird eine Kante gewählt, die in die Höhe geht. Als Abstand die Stockwerkhöhe 16mm definiert und 4 Stockwerke eingetragen.

Bild 41
Bild 41


Als 2. Richtung dann die untere Kante des Gebäudes, Abstand und Anzahl eingeben (hier 11 und 4)

Bild 42
Bild 42


Bestätigen – fertig…

Bild 43
Bild 43


Sehr hilfreich ist oft auch noch die Option „zu umgehende referenzierte Kopien“:

Bild 44
Bild 44


Beim Klicken auf die pinken Knödel werden diese beim Muster übergangen, als Beispiel:

Bild 45
Bild 45


Der Luxus der parametrischen Modellierenslink


Wie schon eingangs erwähnt, wird der Feature-Baum beim jeder Neuberechnung von oben nach unten durchgerechnet, was ein Ändern von bereits bestehenden Features ermöglicht.
Auch wenn hier die Anzahl der Stockwerke mit dem Original übereinstimmt, möchte ich kurz ein Beispiel zeigen, was das bedeutet:
Annahme: wir möchten das Gebäude nun doch lieber mit 5 anstatt 4 Stockwerken ausführen… blöd gelaufen? – Nein…
Wir überlegen uns einfach von oben nach unten durch, welche Feature davon betroffen sind.
Linear austragen 1: Grundkachel – bleibt wie sie ist
Aufsatz LA 1: Grundkörper des Gebäudes – muss höher werden. Also Rechtsklick aufs Feature -> „Feature bearbeiten“ auswählen und wir kommen wieder ins Definitionsmenü des Features. Hier einfach die Höhe von 64 auf 80 erhöhen und bestätigen:

Bild 46
Bild 46


Der Dachaufbau geht sofort mit, die Fenster bleiben wo sie sind – also müssen wir noch eine zusätzliche Reihe Fenster dazu packen…
Also auf Lineare Muster -> Feature bearbeiten und in der 1 Richtung einfach die Anzahl um 1 erhöhen.

Bild 47
Bild 47


2 Features - 1 Flächelink


Wie ebenfalls schon einmal erwähnt kann eine Fläche nicht 2 unterschiedliche Texturen haben. Als Beispiel der Vorbau des Gebäudes:

Bild 48
Bild 48


Die Skizze auf die Seitenwand…

Bild 49
Bild 49


Die Austragung bis zur anderen Seitenwand…

Bild 50
Bild 50


Die Farbgebung – nur ist die Seitenwand in Sandstein geblieben…

Bild 51
Bild 51


Das Problem: die Seitenwand ist eine gemeinsame Fläche mit der Hausmauer…
Die Lösung:

Bild 52
Bild 52


Bei „Von“ einen Offset von 0.1mm definieren und bei „Richtung 1“ einen Offset von 0.1mm.

Bild 53
Bild 53


Das Ergebnis…

Bild 54
Bild 54


Im Detail entsteht eine kleine Stufe im Modell, die allerdings im Renderexport nicht mehr ersichtlich ist… (entspricht 0.1 Pixel….!)

Übung macht den Meister...link


Als geübter SWX’ler benötigt man bis hierher ca. 3-4 Minuten – als Newbie wird man sich sicherlich etwas mehr Zeit dafür nehmen müssen. Natürlich ist auch die Hardware-Technische Ausrüstung nicht zu unterschätzen – mit einem halbwegs guten Rechner lässt sich allerdings schon so einiges anfangen, für sehr komplexe Bauwerke wie Kirchen oder ähnlich braucht’s dann aber schon eine anständige Mühle.

Sehr gut arbeite ich mit 10-Tasten-Maus und zusätzlichem Nummernblock für die linke Hand – das ist aber Geschmackssache und für den Hobbywerkler sicherlich kein Muss… bei mir ist das Rendern ja nur ein bissl nebenbei, das Hauptaugenmerk liegt auf anderen Tätigkeiten im 3D.
Für schnellen Zugriff auf Befehle kann man sich die „Shortcutleiste“ ein wenig zu Nutze machen. Diese erscheint standardmäßig auf Tastendruck „S“ direkt neben der Maus und man kann mit Rechtsklick drauf -> „Anpassen“ diese nach seinem eigenen Geschmack zusammenstellen.
Was man sich auch von Anfang an angewöhnen sollte, ist ein sinnvoller Aufbau des 3D-Modells und eine sinnvolle Vergabe der Referenzen. Ist keine große Wissenschaft, allerdings sollte man z.B. Fenster von einer Mauerkante und nicht vom Gartenzaun weg bemaßen – das bringt vor allem dann Vorteile, wenn man von einem 3D-Modell Variationen erstellen und somit mehrere Renderexporte erstellen möchte.

An dieser Stelle sind eigentlich alle notwendigen Grundlagen des 3D-Modellierens erklärt. Wenn man die Schritte ein paar mal durchgemacht und verstanden hat, sollte es absolut kein Problem sein eigene Gebäude zu kreiren. In den nächsten Beiträgen möchte ich noch ohne grosse Worte das Gebäude fertig wachsen lassen, bevor es dann ans endgültige Rendern und Nachbearbeiten mit Gimp geht.

Das Gebäude in Skizzen und Featureslink


Bild 55
Bild 55


Bild 56
Bild 56


Bild 57
Bild 57


Bild 58
Bild 58


Bild 59
Bild 59


Bild 60
Bild 60


Bild 61
Bild 61


Bild 62
Bild 62


Bild 63
Bild 63


Bild 64
Bild 64


Bild 65
Bild 65


Bild 66
Bild 66


Bild 67
Bild 67


Bild 68
Bild 68


Bild 69
Bild 69


Bild 70
Bild 70


Bild 71
Bild 71


Bild 72
Bild 72


Bild 73
Bild 73


Bild 74
Bild 74


Bild 75
Bild 75


Bild 76
Bild 76


Bild 77
Bild 77


Bild 78
Bild 78


Bild 79
Bild 79


Bild 80
Bild 80


Bild 81
Bild 81


Bild 82
Bild 82


Bild 83
Bild 83


Bild 84
Bild 84


Bild 85
Bild 85


Renderexportlink

Wir betrachten nun unser Gebäude als fertig. Da wir aber Grafikdateien benötigen um weiterarbeiten zu können, müssen wir die Renderings nun exportieren:

  1. Feature-Baum einklappen (mit den 3 kleinen Dreiecken am rechten Rand des Feature-Baumes)
Bild 86
Bild 86

  1. In die Render 1 Ansicht drehen
  2. Taste “F” drücken, um das Gebäude möglichst groß und zentriert im Bildbereich zu haben
Bild 87
Bild 87

  1. In der Office-Produkte Leiste den Befehl „In Datei Rendern“ wählen
Bild 88
Bild 88

Ich hänge an den Dateinamen immer das Kürzel r+Nummer an – das kann natürlich jeder selber gestalten – wichtig ist noch den Dateitypen auf *.png umzustellen.
Bild 89
Bild 89

  1. Die Schritte für die Ansichten Render 2 bis Render 4 wiederholen
  2. In unserem Zielordner befinden sich nun folgende Bilder:
Bild 90
Bild 90

Bild 91
Bild 91

Bild 92
Bild 92

Bild 93
Bild 93


Ein notwendiges Übel - Nachbearbeiten mit Gimplink


Den Renderexporten fehlt es jetzt noch an der richtigen Größe und auch sind noch jede Menge Teiltransparenzen vorhanden, die Simutrans nicht verarbeiten kann. Hier Schritt für Schritt die Anleitung:

Bild 94
Bild 94


Man öffne ganz schlicht das erste File und wähle Bild -> Automatisch zuschneiden

Bild 95
Bild 95


Filter -> Verbessern -> Schärfen (Wert so 15-20)

Bild 96
Bild 96


Bild -> Skalieren

Bild 97
Bild 97


WICHTIG: Breite 130 setzen (nicht 128!!!)

Bild 98
Bild 98


Filter -> Verbessern -> Schärfen (wieder so 15-20)

Bild 99
Bild 99


Alles markieren (strg + A), kopieren (strg + C) und dann kann dieses File geschlossen werden
Vorlage1x1.xcf öffnen (gibt es bei mir)

Bild 100
Bild 100


“Neue Ebene” auswählen und einfügen

Bild 101
Bild 101


Verschieben Werkzeug auswählen und das Gebäude verschieben und zwar so:

Bild 102
Bild 102


Bild 103
Bild 103


GIMP zeigt mit der strichlierten Umrandung an, welche Pixel einen Deckwert von über 50% haben. Die linke Ecke dieser Pixel soll genau auf der linken Kante der Grundkachel liegen (hier Pixel 224).
Von hier kommt auch die Skalierung auf 130 Pixel, da die 2 äußersten Pixel in 95% aller Bilder einen Deckwert von unter 50% haben und deshalb aus dem Bild verschwinden…

Bild 104
Bild 104


Rechtsklick auf „Schwebende Auswahl“ -> Ebene verankern

Bild 105
Bild 105


Rechtsklick auf „Neue Ebene“ -> Ebenenmaske hinzufügen

Bild 106
Bild 106


Alphakanal der Ebene übernehmen

Bild 107
Bild 107


Darauf achten, dass die Maske aktiviert ist (weisser Rahmen)
Dann Farben -> Schwellwert

Bild 108
Bild 108


Nun sind alle Teiltransparenzen aus dem Bild entfernt.

Bild 109
Bild 109


Ab und zu – nicht vorhersagbar – sind Ränder etwas ausgefranst, dazu die Ebenenmaske anzeigen:

Bild 110
Bild 110


Bild 111
Bild 111


Und mit einem kleinen Stift geradepinseln:

Bild 112
Bild 112


Dabei aufpassen, dass keine Teiltransparenzen entstehen (also Grautöne in der Maske)

Bild 113
Bild 113


Das ganze wieder als *.png abspeichern – fertig

Bild 114
Bild 114


Das Ganze noch für die restlichen 3 Ansichten und fertig


Rate this page:

Contributors to this page: Frank .
Page last modified on Thursday October 31, 2019 21:55:56 CET by Frank.

Online Users

7 online users

Newest Forum Posts

No records to display